Server Status

Microsoft Azure outage affecting Xbox connectivity

Incident Report for NBA 2K Server Status Page

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 00:17 UTC

Identified

Xbox is working on it now. https://support.xbox.com/xbox-live-status
Posted Oct 29, 2025 - 19:15 UTC

Investigating

We are currently investigating this issue.
Posted Oct 29, 2025 - 19:09 UTC
This incident affected: Game Platforms (Xbox Live).